Wed, 22 May 2019

In the coming weeks and in a continued commitment to provide online security, AmeriNat will be upgrading the security settings of the LoanLink website. The website will no longer support SSL, or TLS 1.0 over HTTPS which means older browsers that do not support TLS 1.1 & TLS 1.2 will no longer work. For your continued online security, please ensure that you are using a current and secure web browser. click here for FAQ's on TLS Security Questions.

Click here to test your browser compatibility.

Browser Support: The following browsers are not supported using TLS 1.1 & TLS 1.2.

If you have any questions or concerns regarding this change, please feel free to contact us at customerservice@amerinatls.com.


ABOUT SSL CERTIFICATES